Cosmos found serious security vulnerabilities, nodes and service providers need to upgrade software

The Cosmos Forum today issued a notice stating that it has discovered a serious security vulnerability affecting all versions of Tendermint, which was reported to the Tendermint bug bounty program. The team said that the patch for the problem does not require any disruptive changes, and the verifier and service provider only need to update the software at 2 pm on October 2, Beijing time. The latest software will be released in Tendermint's 0.31.9 and 0.32.5 versions, as well as the 0.34.8 version of the Cosmos SDK.